Author Topic: Engine idles fine but revs die when trying to pull away  (Read 101 times)

0 Members and 1 Guest are viewing this topic.

Offline jasonrb

  • S Class
  • *
  • Posts: 1
  • Gender: Male
  • Engine: 2.0L
  • Fuel: Diesel
  • Transmission: Manual
  • Trim: TS2
  • Year: 2011
Engine idles fine but revs die when trying to pull away
« on: June 07, 2019, 04:54:58 am »
Hi guys, I’ve got a 2006 Mazda 6 ts 2 Ltd diesel.
All of sudden it’s started to have problems revving up. The car will idle fine with no fluttering on the revs , but if you tr6 to rev it it gets to 1500 rpm then drops off. It will then accelerate again but at 1500 same issue.
I called breakdown out and they had no idea. I thought it might have been the scv so I swapped it but no change.

Has anyone seen this or got any ideas ? I think power was down a bit recently too but didn’t do much driving to test it.

This is my first Mazda so I’m learning as I’m doing with it. Nice car and not had it long so would love some good news


Offline apav

  • Takara Class
  • *****
  • Posts: 354
  • Gender: Male
  • Engine: 2.0L
  • Fuel: Diesel
  • Transmission: Manual
  • Trim: TS2
  • Year: 2009
Re: Engine idles fine but revs die when trying to pull away
« Reply #1 on: June 07, 2019, 07:21:27 am »
It could be anything but first try to change the oil and the filters (oil, air, fuel) to have some starting point.

Just be careful with revving as these engines are quite sensitive with the oil and you do not know what is in there or whether the injectors leak.

If your oil and the injectors are fine, and have a fresh fuel but still there problem is there, you have to go through various sensors and turbo checks.