Author Topic: Mazda 6 Sport 2016 2.2 - Faulty Sensors  (Read 271 times)

0 Members and 1 Guest are viewing this topic.

Offline Zielonyman

  • S Class
  • *
  • Posts: 2
  • Gender: Male
  • Engine: 2.2L
  • Fuel: Diesel
  • Transmission: Manual
  • Trim: Sport Nav
  • Year: 2016
Mazda 6 Sport 2016 2.2 - Faulty Sensors
« on: December 01, 2021, 08:40:46 pm »
Hello All,

For a while, I've been experiencing intermittent issues with my Mazda 6.
My car does struggle sometimes whilst cruising between 1.8-2.5k rpm (as if it was choking, also hesitatates during acceleration).
It seems like the fuel consumption is higher than it should be.

I had it checked by a mechanic and no faults were found.
Had it fully serviced, replaced SCV valve, had the engine carbon cleaned which helped for a few days.
I've cleaned MAF & MAP sensors, which helped further (MAP was completely covered with carbon).
I wanted to get my EGR and Intake Manifold cleaned next (walnut blasting) as I suspect EGR valve could be causing it (DPF would be next on my list).

Whilst checking the live data I've noticed that:
-Charge Air Cooler Temperature Sensor 1 (Bank 1) is stuck at -40 degrees Celcius
-Exhaust Gas Temperature Sensor 4 (Bank 1) is also stuck at -40 degrees Celcius

I'm not sure what the correct temperature should be, but the fact that it doesn't change would suggest these sensors are faulty.

Have you experienced similar issues?
Do you know where are these sensors located?
What are your readings for these 2 sensors?

I've purchased a Haynes Manual for my car but it seems like it does not contain this information.

I would much appreciate it if you could help me out

Many Thanks