Author Topic: 2.0 Diesel Lagging at Low Revs.  (Read 5517 times)

0 Members and 1 Guest are viewing this topic.

Offline neilsheff

  • S Class
  • *
  • Posts: 5
  • Gender: Male
  • Colour: Black Mica (16W) Metallic
  • Engine: 2.0L
  • Fuel: Diesel
  • Transmission: Manual
  • Trim: TS
  • Year: 2006
2.0 Diesel Lagging at Low Revs.
« on: December 08, 2011, 10:54:29 am »
Does anyone have an idea why my Mazda 6 2.0 Diesel has just started to occasionally lag when I accelerate to set off from lights etc. I get a delay at low revs (under 2000) where the rev counter stays where it is, and then suddenly starts to accelerate as per normal.  This can sometimes only last a moment but can last up to 10 seconds. During this fault the engine sounds totally normal and smooth, there is no spluttering or juddering or anything, just no power.

This mainly seems to happen when the car is cold or on the start of a journey. I have never had any problems so far with the engine, it is currently on around 55,000 miles.

Hope someone can advise me,

Many Thanks,

Neil.

Offline SRRAE

  • S Class
  • *
  • Posts: 17
  • Gender: Male
  • Colour: Black Mica (16W) Metallic
  • Engine: 2.0L
  • Fuel: Diesel
  • Transmission: Manual
  • Trim: Sport
  • Year: 2005
Re: 2.0 Diesel Lagging at Low Revs.
« Reply #1 on: December 15, 2011, 12:33:12 pm »
Its probably a safety feature to stop people hard accelerating while the engine is cold.
My Nissan 300ZX goes to safety boost mode when the engine is cold and thats a 20 year old car.

Offline MJ

  • S Class
  • *
  • Posts: 2
  • Gender: Male
  • Engine: 2.0L
  • Fuel: Diesel
  • Transmission: Manual
  • Trim: TS2
  • Year: 2008
Re: 2.0 Diesel Lagging at Low Revs.
« Reply #2 on: December 21, 2011, 10:11:38 am »
Hi there

First post so here goes.

My 6 also does this on occasion for the first 5-6 miles or so I have assumed it is something to do with the need for the car to warm up to full operating temperature.

Can anyone confirm this.

Thanks

Offline m.j.holroyd

  • S Class
  • *
  • Posts: 7
  • Gender: Male
  • Engine: 2.0L
  • Fuel: Diesel
  • Transmission: Manual
  • Trim: TS2
  • Year: 2008
Re: 2.0 Diesel Lagging at Low Revs.
« Reply #3 on: February 16, 2012, 07:51:28 pm »
Hi,Neil
         Don't know if your still having probs with accelerating,but your issue sounds very familiar to one i had with my old laguna. My problem was diagnosed as the e.g.r valve.Where it gets  clogged and sooted up with carbon, build-up.

         Happy to be corrected if anyone knows otherwise.